استكشاف مشكلات تحديث Microsoft Security Essentials وإصلاحها

يعمل Microsoft Security Essentials تلقائيًا مع Microsoft Update لضمان تحديث تعريفات الفيروسات وبرامج التجسس باستمرار.

الأعراض

فيما يلي بعض المشكلات الشائعة المتعلقة بالتحديثات التلقائية:

  • تشاهد رسائل خطأ تشير إلى فشل التحديثات.

  • عند التحقق من وجود تحديثات، ستتلقى رسالة خطأ تفيد بأنه يتعذر التحقق من وجود تحديثات تعريفات الفيروسات أو برامج التجسس أو تنزيلها أو تثبيتها.

  • ستفشل التحديثات حتى إذا كنت متصلاً بالإنترنت.

  • لا يتم تثبيت التحديثات تلقائيًا على النحو المجدول.

السبب

الأسباب الشائعة لمشكلات التحديث هي المشكلات التي تحدث في الاتصال بالإنترنت. وإذا كنت متصلاً بالإنترنت، فقد يكون سبب المشكلة هو وجود تعارضات مع الإعدادات الموجودة في Windows Internet Explorer.

الحل

هام:

يجب إنهاء Internet Explorer لإكمال هذه الخطوات. وبالتالي؛ يجب طباعتها أو تدوينها أو نسخها في ملف آخر، ثم وضع إشارة مرجعية على هذا الموضوع للرجوع إليه في المستقبل.

الخطوة 1: إعادة تعيين إعدادات Internet Explorer

  1. قم بإنهاء جميع البرامج المفتوحة، بما فيها Internet Explorer.

    ملاحظة:
    تؤدي إعادة تعيين هذه الإعدادات في Internet Explorer إلى حذف الملفات المؤقتة وملفات تعريف الارتباط ومحفوظات الاستعراض وكلمات المرور عبر الإنترنت. ومع ذلك؛ فلن يتم حذف المفضلات.

  2. انقر فوق ابدأ، وفي المربع بدء البحث، اكتب inetcpl.cpl، ثم اضغط على Enter.

  3. في مربع الحوار خيارات إنترنت، انقر فوق علامة التبويب خيارات متقدمة.

  4. ضمن إعادة تعيين إعدادات Internet Explorer، انقر فوق إعادة تعيين، ثم انقر فوق إعادة تعيين مرة أخرى.

  5. انتظر حتى ينتهي Internet Explorer من إعادة تعيين الإعدادات، ثم انقر فوق موافق.

  6. افتح Internet Explorer.

  7. افتح Microsoft Security Essentials، وانقر فوق علامة التبويب تحديث، ثم انقر فوق تحديث. وإذا استمرت المشكلة، فانتقل إلى الخطوة التالية.

الخطوة 2: تعيين Internet Explorer كمستعرض افتراضي

  1. قم بإنهاء جميع البرامج المفتوحة، بما فيها Internet Explorer.

  2. انقر فوق ابدأ، وفي المربع بدء البحث، اكتب inetcpl.cpl، ثم اضغط على Enter.

  3. في مربع الحوار خيارات إنترنت، انقر فوق علامة التبويب البرامج.

  4. ضمن مستعرض ويب الافتراضي، انقر فوق الافتراضي. انقر فوق موافق.

  5. افتح Microsoft Security Essentials. انقر فوق علامة التبويب تحديث، ثم انقر فوق تحديث. وإذا استمرت المشكلة، فانتقل إلى الخطوة التالية.

الخطوة 3: تأكد من ضبط التاريخ والوقت بشكل صحيح على الكمبيوتر

  1. افتح Microsoft Security Essentials.

  2. إذا كانت رسالة الخطأ التي تتلقاها تحتوي على الرمز 0x80072f8f، فمن المحتمل أن يكون سبب المشكلة هو عدم صحة إعداد التاريخ أو الوقت على الكمبيوتر لديك.

  3. لإعادة تعيين إعداد تاريخ الكمبيوتر أو وقته، اتبع الخطوات الموجودة في إصلاح اختصارات سطح المكتب المعطلة ومهام صيانة النظام الشائعة (http://go.microsoft.com/fwlink/?LinkId=155579).

الخطوة 4: إعادة تسمية مجلد "Software Distribution" على الكمبيوتر

  1. أوقف خدمة التحديثات التلقائية

    1. انقر فوق ابدأ، وانقر فوق تشغيل، واكتب services.msc، ثم انقر فوق موافق.

    2. انقر بزر الماوس الأيمن فوق خدمة التحديثات التلقائية، ثم انقر فوق إيقاف.

    3. قم بتصغير الأداة الإضافية للخدمات.

  2. إذا كانت رسالة الخطأ التي تتلقاها تحتوي على الرمز 0x80072f8f، فمن المحتمل أن يكون سبب المشكلة هو عدم صحة إعداد التاريخ أو الوقت على الكمبيوتر لديك.

  3. أعد تسمية دليل SoftwareDistribution على النحو التالي:

    1. انقر فوق ابدأ، وانقر فوق تشغيل، واكتب cmd، ثم انقر فوق موافق.

    2. اكتب cd %windir%، ثم اضغط على Enter.

    3. اكتب ren SoftwareDistribution SDTemp، ثم اضغط على Enter.

    4. اكتب exit، ثم اضغط على Enter.

  4. ابدأ خدمة التحديثات التلقائية على النحو التالي:

    1. قم بتكبير الأداة الإضافية للخدمات.

    2. انقر بزر الماوس الأيمن فوق خدمة التحديثات التلقائية، ثم انقر فوق بدء.

    3. أغلق الأداة الإضافية للخدمات.

الخطوة 5: إعادة تعيين محرك تحديث مكافحة الفيروسات من Microsoft على الكمبيوتر

  1. انقر فوق ابدأ، وانقر فوق كافة البرامج، وانقر فوق البرامج الملحقة، ثم انقر بزر الماوس الأيمن فوق موجّه الأوامر، ثم حدد التشغيل كمسؤول.

  2. في النافذة موجّه الأوامر، أدخل الأوامر التالية ثم اضغط على Enter بعد كل أمر:

    • Cd\

    • Cd program files\microsoft security essentials

    • Mpcmdrun –removedefinitions –all

    • Exit

  3. أعد تشغيل الكمبيوتر الخاص بك.

  4. افتح Microsoft Security Essentials، وانقر فوق علامة التبويب تحديث، ثم انقر فوق تحديث. وإذا استمرت المشكلة، فانتقل إلى الخطوة التالية.

الخطوة 6: تثبيت تحديثات تعريفات الفيروسات وبرامج التجسس يدويًا

  • إذا كنت تقوم بتشغيل الإصدار 32 بت من نظام تشغيل Windows، فقم بتنزيل آخر التحديثات يدويًا على http://go.microsoft.com/fwlink/?LinkID=87342 (http://go.microsoft.com/fwlink/?LinkID=87342).

  • إذا كنت تقوم بتشغيل الإصدار 64 بت من نظام تشغيل Windows، فقم بتنزيل آخر التحديثات يدويًا على http://go.microsoft.com/fwlink/?LinkID=87341 (http://go.microsoft.com/fwlink/?LinkID=87341).

  • انقر فوق تشغيل. سيتم تثبيت آخر التحديثات على الكمبيوتر يدويًا.

الخطوة 7: الاتصال بالدعم

  • إذا لم تعمل هذه الخطوات على حل المشكلة، فاتصل بالدعم. لمزيد من المعلومات، راجع دعم العملاء (http://go.microsoft.com/fwlink/?LinkID=196174).