Poradce při potížích s aktualizací programu Microsoft Security Essentials
Program Microsoft Security Essentials ve spolupráci se systémem Microsoft Update automaticky zajišťuje, aby byly definice virů a spywaru stále aktuální.
Příznaky
Při automatické aktualizaci může občas dojít k následujícím potížím:
-
Zobrazí se zpráva, že se aktualizace nezdařila.
-
Během kontroly aktualizací se zobrazí chybová zpráva, že aktualizaci definic virů a spywaru nelze vyhledat, stáhnout nebo nainstalovat.
-
Aktualizace se nezdaří, přestože jste připojeni k Internetu.
-
Aktualizace se automaticky neinstalují podle plánu.
Příčina
Nejčastější příčina potíží při aktualizaci souvisí s připojením k Internetu. Pokud jste právě online, mohou být potíže způsobeny konfliktem v nastavení prohlížeče Windows Internet Explorer.
Řešení
Důležité:
Aby bylo možné následující postup provést, je nutné ukončit aplikaci Internet Explorer. Proto si postup vytiskněte, zapište nebo zkopírujte do jiného souboru a pak přidejte tuto stránku do oblíbených, abyste ji v budoucnu snadno našli.
Krok 1: Obnovení nastavení aplikace Internet Explorer
-
Ukončete všechny spuštěné programy včetně aplikace Internet Explorer.
Poznámka:
Při obnovení nastavení aplikace Internet Explorer budou odstraněny dočasné soubory, soubory cookie, historie procházení i uložená hesla k webům. Nebudou však odstraněny oblíbené položky.
-
Klikněte na tlačítko Start, do pole Zahájit hledání zadejte text inetcpl.cpl a poté stiskněte klávesu ENTER.
-
V dialogovém okně Možnosti Internetu klikněte na kartu Upřesnit.
-
V části Obnovit nastavení aplikace Internet Explorer klikněte na tlačítko Obnovit a poté znovu klikněte na tlačítko Obnovit.
-
Počkejte, než aplikace Internet Explorer dokončí obnovování nastavení, a pak klikněte na tlačítko OK.
-
Spusťte aplikaci Internet Explorer.
-
Spusťte Microsoft Security Essentials a na kartě Aktualizace klikněte na tlačítko Aktualizovat. Pokud se tím problém nevyřeší, pokračujte dalším krokem.
Krok 2: Nastavení aplikace Internet Explorer jako výchozího prohlížeče
-
Ukončete všechny spuštěné programy včetně aplikace Internet Explorer.
-
Klikněte na tlačítko Start, do pole Zahájit hledání zadejte text inetcpl.cpl a poté stiskněte klávesu ENTER.
-
V dialogovém okně Možnosti Internetu klikněte na kartu Programy.
-
V části Výchozí webový prohlížeč klikněte na tlačítko Nastavit jako výchozí. Klikněte na tlačítko OK.
-
Spusťte aplikaci Microsoft Security Essentials. Na kartě Aktualizace klikněte na tlačítko Aktualizovat. Pokud se tím problém nevyřeší, pokračujte dalším krokem.
Krok 3: Nastavení správného data a času v počítači
-
Spusťte aplikaci Microsoft Security Essentials.
-
Jestliže zobrazená chybová zpráva obsahuje kód 0x80072f8f, byly potíže pravděpodobně způsobeny chybným nastavení data nebo času v počítači.
-
Chcete-li v počítači obnovit nastavení data nebo času, postupujte podle pokynů v článku Oprava neplatných zástupců na ploše a běžná údržba systému.
Krok 4: Přejmenování složky Software Distribution v počítači
-
Zastavte službu automatických aktualizací:
-
Klikněte na tlačítko Start, klikněte na položku Spustit, zadejte text services.msc a poté klikněte na tlačítko OK.
-
Klikněte pravým tlačítkem myši na položku Automatické aktualizace a poté klikněte na příkaz Zastavit.
-
Minimalizujte okno modulu snap-in Služby.
-
Jestliže zobrazená chybová zpráva obsahuje kód 0x80072f8f, byly potíže pravděpodobně způsobeny chybným nastavení data nebo času v počítači.
-
Přejmenujte v počítači složku Software Distribution:
-
Klikněte na tlačítko Start, klikněte na položku Spustit, zadejte text cmd a poté klikněte na tlačítko OK.
-
Zadejte příkaz cd %windir% a stiskněte klávesu ENTER.
-
Zadejte příkaz ren SoftwareDistribution SDTemp a stiskněte klávesu ENTER.
-
Zadejte příkaz exit a stiskněte klávesu ENTER.
-
Spusťte službu automatických aktualizací:
-
Maximalizujte okno modulu snap-in Služby.
-
Klikněte pravým tlačítkem myši na položku Automatické aktualizace a poté klikněte na příkaz Spustit.
-
Zavřete okno modulu snap-in Služby.
Krok 5: Obnovení stavu aktualizačního modulu aplikace Microsoft Security Essentials
-
Klikněte na tlačítko Start, položku Všechny programy, přejděte na položku Příslušenství, klikněte pravým tlačítkem na odkaz Příkazový řádek a potom klikněte na příkaz Spustit jako správce.
-
V okně příkazového řádku zadejte následující příkazy a po každém z nich stiskněte klávesu ENTER:
-
Restartujte počítač.
-
Spusťte Microsoft Security Essentials a na kartě Aktualizace klikněte na tlačítko Aktualizovat. Pokud se tím problém nevyřeší, pokračujte dalším krokem.
Krok 6: Ruční instalace aktualizovaných definic virů a spywaru
Krok 7: Kontaktování podpory