Why am I receiving a message about Microsoft Security Essentials or Microsoft Forefront Client Security when installing a service pack?

If you try to install or uninstall Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1 with Microsoft Security Essentials or Microsoft Forefront Client Security already installed on your computer, your security program might prevent the successful installation or removal of the service pack. To avoid this issue, install the latest updates to Microsoft Security Essentials or Forefront Client Security.

Microsoft Security Essentials

  1. Find out if Microsoft Security Essentials is installed on your computer by clicking the Start button Picture of the Start button, clicking Control Panel, and then, under Programs, clicking Uninstall a program.
  2. If Microsoft Security Essentials appears in the list, it's installed on your computer. Check the version number to make sure Version 1.0.1963.0 or later is installed. If the correct version isn't installed, follow the next steps in this section. (Or, if Microsoft Security Essentials doesn't appear in the list, skip the rest of this section.)

  3. Click the Start button Picture of the Start button, type Microsoft Update in the search box, and then click Check for updates.
  4. Select Microsoft Security Essentials Client update package - KB2254596 , click Install updates, and then wait for the installation to finish.

    Note

  5. Install or uninstall Windows 7 SP1 or Windows Server 2008 R2 SP1 by following the steps you were using before the error message appeared.

Microsoft Forefront Client Security

  1. Find out if Microsoft Forefront Client Security is installed on your computer by clicking the Start button Picture of the Start button, clicking Control Panel, and then, under Programs, clicking Uninstall a program.
  2. If Microsoft Forefront Client Security Antimalware Service, Microsoft Forefront Client Security State Assessment Service, or Microsoft Forefront Client Security appear in the list, Microsoft Forefront Client Security is installed on your computer. Check the version number to make sure the FCS v1 update or later is installed. To do this, click View installed updates in the left pane, then review the items under the Microsoft Windows heading to see if Update 2394433 was installed. If the correct version isn't installed, go to step 3. (Or, if Microsoft Forefront Client Security Antimalware Service, Microsoft Forefront Client Security State Assessment Service, or Microsoft Forefront Client Security don't appear in the list, skip the rest of this article.)

  3. Contact your network administrator for assistance, or go to the Microsoft Forefront Client Security antimalware article on the Microsoft website for instructions on installing the Forefront Client Security update.

  4. Install or uninstall Windows 7 SP1 or Windows Server 2008 R2 SP1 by following the steps you were using before the error message appeared.

Note