Risoluzione dei problemi relativi agli aggiornamenti per Microsoft Security Essentials

Microsoft Security Essentials interagisce automaticamente con Microsoft Update per mantenere aggiornate le definizioni di virus e spyware.

Sintomi

Di seguito sono riportati alcuni problemi comuni che possono verificarsi con gli aggiornamenti automatici:

  • Messaggi di errore indicano che gli aggiornamenti non sono riusciti.

  • Quando verifichi la disponibilità di eventuali aggiornamenti, ricevi un messaggio di errore che indica che non è possibile verificare, scaricare né installare gli aggiornamenti delle definizioni di virus e spyware.

  • Anche se sei connesso a Internet, gli aggiornamenti non vengono eseguiti.

  • Gli aggiornamenti non vengono installati automaticamente come da pianificazione.

Causa

Le cause più comuni dei problemi relativi agli aggiornamenti riguardano la connettività Internet. Se sei online, il problema potrebbe essere causato da conflitti con le impostazioni in Windows Internet Explorer.

Soluzione

Importante:

Esci da Internet Explorer per completare questi passaggi. Pertanto, stampali, annotali o copiali in un altro file, quindi inserisci un segnalibro in questo argomento per un accesso futuro.

Passaggio 1: Reimposta le impostazioni di Internet Explorer

  1. Esci da tutti i programmi aperti, incluso Internet Explorer.

    Nota:
    La reimpostazione di queste impostazioni in Internet Explorer comporta l'eliminazione dei file temporanei, dei cookie, della cronologia esplorazioni e delle password online. I preferiti non verranno eliminati.

  2. Fai clic su Start, quindi digita inetcpl.cpl nella casella Inizia ricerca, quindi premi Invio.

  3. Nella finestra di dialogo Opzioni Internet fai clic sulla scheda Avanzate.

  4. In Reimposta Internet Explorer fai clic su Reimposta, quindi nuovamente su Reimposta.

  5. Attendi finché la reimpostazione delle impostazioni di Internet Explorer non viene completata, quindi fai clic su OK.

  6. Apri Internet Explorer.

  7. Apri Microsoft Security Essentials, fai clic sulla scheda Aggiorna, quindi scegli Aggiorna. Se il problema persiste, procedi al passaggio successivo.

Passaggio 2: Imposta Internet Explorer come browser predefinito

  1. Esci da tutti i programmi aperti, incluso Internet Explorer.

  2. Fai clic su Start, quindi digita inetcpl.cpl nella casella Inizia ricerca, quindi premi Invio.

  3. Nella finestra di dialogo Opzioni Internet fai clic sulla scheda Programmi.

  4. In Web browser predefinito fai clic su Predefinito. Fai clic su OK.

  5. Apri Microsoft Security Essentials. Fai clic sulla scheda Aggiorna, quindi scegli Aggiorna. Se il problema persiste, procedi al passaggio successivo.

Passaggio 3: Assicurati che la data e l'ora siano impostate correttamente nel PC

  1. Apri Microsoft Security Essentials.

  2. Se il messaggio di errore ricevuto contiene il code 0x80072f8f, il problema è con tutta probabilità causato dall'impostazione errata di data e ora nel PC.

  3. Per reimpostare la data o l'ora nel PC, effettua i passaggi in Risoluzione dei problemi relativi ai collegamenti sul desktop interrotti e alle attività di manutenzione del sistema comuni.

Passaggio 4: Rinominare la cartella Distribuzione software nel PC

  1. Arresta il servizio Aggiornamenti automatici

    1. Fai clic su Start, scegli Esegui, digita services.msc, quindi scegli OK.

    2. Fai clic con il pulsante destro del mouse sul servizio Aggiornamenti automatici, quindi scegli Arresta.

    3. Riduci a icona lo snap-in Servizi.

  2. Se il messaggio di errore ricevuto contiene il code 0x80072f8f, il problema è con tutta probabilità causato dall'impostazione errata di data e ora nel PC.

  3. Rinomina la directory SoftwareDistribution nel modo seguente:

    1. Fai clic su Start, scegli Esegui, digita cmd, quindi scegli OK.

    2. Digita cd %windir%, quindi premi Invio.

    3. Digita ren SoftwareDistribution SDTemp, quindi premi Invio.

    4. Digita exit, quindi premi Invio.

  4. Avvia il servizio Aggiornamenti automatici nel modo seguente:

    1. Ingrandisci lo snap-in Servizi.

    2. Fai clic con il pulsante destro del mouse sul servizio Aggiornamenti automatici, quindi scegli Avvia.

    3. Chiudi la finestra dello snap-in Servizi.

Passaggio 5: Reimpostare il motore di aggiornamento antivirus Microsoft nel PC

  1. Fai clic su Start, scegli Tutti i programmi, Accessori, quindi fai clic con il pulsante destro del mouse su Prompt dei comandi, quindi seleziona Esegui come amministratore.

  2. Nella finestra Prompt dei comandi, digita i comandi seguenti e premi Invio dopo ciascun comando:

    • Cd\

    • Cd programmi\microsoft security essentials

    • Mpcmdrun –removedefinitions –all

    • Exit

  3. Riavviare il PC.

  4. Apri Microsoft Security Essentials, fai clic sulla scheda Aggiorna, quindi scegli Aggiorna. Se il problema persiste, procedi al passaggio successivo.

Passaggio 6: Installare manualmente gli aggiornamenti delle definizioni di virus e spyware

Passaggio 7: Contattare il supporto

  • Se il problema persiste, contattare il supporto. Per ulteriori informazioni, vedi il Supporto tecnico.